My CentOS 7 VPS is not booting up, how do I fix this?

To make it easier to get in touch with us, from the 24th of March 2016 all support tickets will need to be submitted from your Crucial Control Panel.

We have become aware of an issue with booting up a Barebones VPS running CentOS 7. There is a high chance of this occurring if updates have been run recently. Below are the steps to resolve this.

  1. Login to the Advanced Control Panel (login details are the same as the Control Panel / My Account area)
  2. Click on 'Virtual Servers' and then click on the name of the server having issues



  3. You will likely see a failed reboot or startup log



  4. Click onto 'Tools' and then 'Startup on Recovery'



  5. Click 'Ok' in the pop up that appears
  6. Once the server has been rebooted, click on 'Console' at the top of the screen



  7. When the console screen appears, log into the VPS using 'root' as the username, and the current root password
  8. Type 'fdisk -l'



  9. You should see an entry similar to the below picture, which will display a size that is slightly larger then the disk of your VPS (26.8GB in the picture).

    Take note of the disk name (/dev/xvdb1 in the picture)



  10. Type in 'mount [disk name] /mnt' (In the above screenshot this would be 'mount /dev/xvdb1 /mnt')



  11. You can verify that the disk is mounted by typing 'ls /mnt'
  12. Type 'vi /mnt/boot/grub/grub.conf'
  13. Using the arrow keys on your keyboard navigate to the setting for 'default'



  14. Press 'R' and then '2', this should change the number to '2'



  15. Save this by pressing ':wq' and pressing enter
  16. Close the console window and reboot the server normally



  17. The server should now boot up normally

If your server is still not booting up normally, there could be another problem causing this, and you are recommended to contact Support to resolve this.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk